Overview
Your District is using Infinite Campus software as the School Information System (SIS) to integrate with School Loop and multiple Teachers and/or Admins at your District's schools are seeing the error "No data import!". This article explains why this happens and provides a solution for the same.
Prerequisites
You are a School Loop District Administrator
Diagnosis
- If your District has recently performed an Infinite Campus software update, then, the imports into School Loop will not work due to a double quotes option introduced from the Infinite Campus' end.
- As mentioned in our article Formatting Data Extracted from SIS for Sloopy, there should be no quotes around data values in the files that are being used to import and extract data from.
- When importing data from the updated Infinite Campus software, it adds double quotes by default to all the data, thus causing the imports to break.
Solution
- In the Infinite Campus software's settings, there is a new setting to include double-quotes. It's called "Include double quotes?", which is checked by default:
- This setting needs to be unchecked and saved.
- Export the files for all the schools in the district and import them using Sloopy again.
Confirmation
All the data in the schools will be updated as expected and the error "No data import!" will not be seen.