Issue
The previous Google Calendar events are not seen on School Loop calendar even after integration.
Environment
All School Loop versions.
Root Cause
The integration only picks up events from the day of integration forward.
Resolution
- Verify if the correct google account has been integrated.
- Navigate to the Site Center found in the Toolbox section of the homepage.
- Go to the Tools tab and click Integrate.
- Verify if the integrated Google account is the one associated with the Calendar.
- If the integrated account is incorrect, click on Disconnect from Google Calendar to remove the incorrect account. Otherwise, proceed to step 2.
- Configure and integrate the correct account that is associated with the calendar content.
- Ensure that the Google account is checked.
- If the checkbox next to the associated Google account is unchecked, the calendar contents are not synchronized.
- Click on the checkbox to select the account and click submit.
- If the checkbox next to the associated Google account is unchecked, the calendar contents are not synchronized.
- Verify if missing events are scheduled prior to integration.
- Check when was the google account integrated.
- The calendar will only display contents scheduled from the day of integration forward. Past events will not be synced.
Confirmation
Click on My Calendar at the top of the page to display your calendar. Google Calendar events are now displayed correctly.