Overview
After the start of a new term, students and parents still see grades for the last term (e.g., semester or quarter) on their portals.
Diagnosis
- Log in to your student (or parent) account and click Progress Report:
- Only grades for the previous term (in this example, for 3rd quarter) are displayed:
This is expected behavior for School Loop - progress reports with the grades for the previous terms are displayed until the teacher publishes grades for the new term.
Solution
If you have completed tasks or tests for the new period, reach out via LoopMail to the corresponding teacher and ask them to:
- Publish at least one assignment worth more than zero points for the current term.
- Grade the assignment and publish the progress report.
Confirmation
Once the teacher confirms that the progress report for the current term has been published, follow the steps in the Diagnosis section. Grades for the new period are displayed.
In this example, a new grade for the 4th quarter is published: