Overview
The teacher or school staff user's School Loop site has been created and published, but it is not linked to the username on the Staff page or it is linked to a different Staff page. The process to link/move the site to the appropriate Staff page is shown here.
Prerequisites
- Webmaster rights are required to investigate and resolve this issue.
Diagnosis
This issue may happen when the user has more than one accounts and the wrong account is added to the Staff Directory. To check if the affected user has multiple accounts, follow the steps below:
- Log in to your School Loop account with Webmaster rights.
- From the Toolbox, select Site Center.
- Open the Tools tab and click Go next to Log into User Sites.
- Check if the user in question has more than one user site - one of them is published (can be clicked) and others are not published.
Solution
You need to add the correct user account to the Staff Directory module:
- Log in to your School Loop account with Webmaster rights.
- From the Toolbox, select Site Center.
- Select the page where the Staff Directory module is added and click Edit.
- Right-click on the Staff Directory module and click Select Staff.
- Search for the user via their first or last name.
- Uncheck the user account that was added to the staff directory and select the account for the same user that was not added before.
Link to the user site is immediately added to the account name. - Click Publish Changes.
Note: If the second user account is unnecessary, you can ask School Admin to remove it to avoid any issues in the future.
Confirmation
- Open the page that contains Staff Directory module.
- Locate the user in question and click on their name.
Their published user site is displayed: