Overview
When trying to register new teachers during summer or at the beginning of the school year, Admins or Principals encounter an issue that the required accounts are not shown on the Register Teachers page or the Teachers' classes don't show up in School Loop.
Diagnosis
Information about teacher accounts is imported from your SIS. If the required accounts are not displayed in School Loop or there are no input boxes (only the Register Now and Cancel buttons), it means that the data was not imported from SIS.
Prerequisites
You need to have access to your SIS. Otherwise, reach out to the person who has this access.
Solution
Check if the required teacher accounts are created in your SIS.
- If not, you need to create the accounts in the SIS first (or ask the person handling SIS to do it). The created accounts will be imported to School Loop during the next data import, which usually run on a daily basis.
- If the accounts were present in your SIS or you have created them and the data is not imported within the next day, reach out to the District Admin who handles Data Imports (Sloopy) for your district - they need to check why data is not being imported to School Loop from your SIS.
Confirmation
On the next day after creating teacher accounts in SIS or once district confirms that the data is imported to School Loop from the SIS, go to User Management > Teachers > Register Teachers.
Teacher accounts along with teacher IDs are listed, and you can proceed to register them.